Jump to content
Sign in to follow this  
Patrik Wedam

Ständig CTD mit ntdll.dll

Recommended Posts

Patrik Wedam

Guten Tag

 

Langsam gehen mir die Ideen aus, wie ich die CTDs untersuchen könnte:

 

Faulting application name: Prepar3D.exe, version: 4.5.12.30293, time stamp: 0x5cd47aad
Faulting module name: ntdll.dll, version: 10.0.18362.719, time stamp: 0x64d10ee0
Exception code: 0xc0000374
Fault offset: 0x00000000000f92a9
Faulting process id: 0x1320
Faulting application start time: 0x01d5fe03604ca317
Faulting application path: P:\P3D\Prepar3D.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 879e8e6b-0972-4dcc-8aa5-08866bd62328
Faulting package full name:
Faulting package-relative application ID:

 

Habe bereits folgendes gemacht, ohne Erfolg.

 

- cfg gelöscht

- shaders gelöscht

- client update

- P3D repair durchgeführt

- ASv4 update

- ORBX update

- ai deaktiviert

- Szenerien deaktiviert

- etc

 

Es trifft vo allem in Deutschland auf zb:

EHAM-LIRF

LSZH-EDDH

ESSA-LSZH

EDDF-LEPA

EDDK sogar noch beim boarding

 

Habt ihr noch eine Idee?

Share this post


Link to post
Share on other sites
Romair
vor 56 Minuten schrieb Patrik Wedam:

Guten Tag

 

Langsam gehen mir die Ideen aus, wie ich die CTDs untersuchen könnte:

 

Faulting application name: Prepar3D.exe, version: 4.5.12.30293, time stamp: 0x5cd47aad
Faulting module name: ntdll.dll, version: 10.0.18362.719, time stamp: 0x64d10ee0
Exception code: 0xc0000374
Fault offset: 0x00000000000f92a9
Faulting process id: 0x1320
Faulting application start time: 0x01d5fe03604ca317
Faulting application path: P:\P3D\Prepar3D.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 879e8e6b-0972-4dcc-8aa5-08866bd62328
Faulting package full name:
Faulting package-relative application ID:

 

Habe bereits folgendes gemacht, ohne Erfolg.

 

- cfg gelöscht

- shaders gelöscht

- client update

- P3D repair durchgeführt

- ASv4 update

- ORBX update

- ai deaktiviert

- Szenerien deaktiviert

- etc

 

Es trifft vo allem in Deutschland auf zb:

EHAM-LIRF

LSZH-EDDH

ESSA-LSZH

EDDF-LEPA

EDDK sogar noch beim boarding

 

Habt ihr noch eine Idee?

Hallo Patrik

 

1. Du hast noch eine ältere P3D Version. Aktuell ist es die P3D-V4.5-Version-4.5.12.30297

 

2. Du solltest  den Client nicht reparieren sondern deinstallieren und wieder installieren.

 

3. Auch den Scenery und Content könntest Du auch deinstallieren und wieder installieren Den Addons passiert da nichts.

 

4. Nach den Deinstallationen den CCleaner durchlaufen lassen und zwar nur der Registry Cleaner.

 

3. Das Problem scheint eher im WIN zu sein. Wie gross ist den Deine ntdll.dll ? Mein hat 1.90 MB

 

4. Hadt Du ORBX Germany Süd installiert und wenn , dann mal deaktivieren.

 

Gib mir Bescheid.

 

Roger und Gruess

 

 

 

 

 

 

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Patrik Wedam
Posted (edited)
vor 2 Stunden schrieb Romair:

Hallo Patrik

 

1. Du hast noch eine ältere P3D Version. Aktuell ist es die P3D-V4.5-Version-4.5.12.30297

 

2. Du solltest  den Client nicht reparieren sondern deinstallieren und wieder installieren.

 

3. Auch den Scenery und Content könntest Du auch deinstallieren und wieder installieren Den Addons passiert da nichts.

 

4. Nach den Deinstallationen den CCleaner durchlaufen lassen und zwar nur der Registry Cleaner.

 

3. Das Problem scheint eher im WIN zu sein. Wie gross ist den Deine ntdll.dll ? Mein hat 1.90 MB

 

4. Hadt Du ORBX Germany Süd installiert und wenn , dann mal deaktivieren.

 

Gib mir Bescheid.

 

Roger und Gruess

 

 

 

 

 

 

 

 

 

 

 

Danke für die schnelle Antwort!

Habe client, scenery und content nun de- und wieder installiert

Danach den registry cleaner durchlaufen lassen

Die ntdll.dll ist bei mir auch ~1.9Mb

ORBX Germany Süd habe ich nicht

 

Werde ich nun in CGN hinstellen uns sehen, wie lange das gut geht.

Edited by Patrik Wedam

Share this post


Link to post
Share on other sites
Romair
Posted (edited)
vor 20 Minuten schrieb Patrik Wedam:

 

Danke für die schnelle Antwort!

Habe client, scenery und content nun de- und wieder installiert

Danach den registrey cleaner durchlaufen lassen

Die ntdll.dll ist bei mir auch ~1.9Mb

ORBX Germany Süd habe ich nicht

 

Werde ich nun in CGN hinstellen uns sehen, wie lange das gut geht.

Habe in Deinem Ablauf einen kleine Fehler bemerkt. Du musst selbstverständlich den CCleaner nach der Deinstallation durchlaufen lassen und nicht erst nach der Neuinstallation.

Die Leichen müssen vor einer Neuinstallation weg sonst können diese wieder Teilüberschrieben werden resp. neu mit altem vermischt werden.

Edited by Romair
  • Like 1

Share this post


Link to post
Share on other sites
Patrik Wedam
Posted (edited)

Leider kein Erfolg>

 

Faulting application name: Prepar3D.exe, version: 4.5.13.32097, time stamp: 0x5d8abf93
Faulting module name: ntdll.dll, version: 10.0.18362.719, time stamp: 0x64d10ee0
Exception code: 0xc0000374
Fault offset: 0x00000000000f92a9
Faulting process id: 0x3670
Faulting application start time: 0x01d5ff615e5beea7
Faulting application path: P:\P3D\Prepar3D.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 1b574c71-7253-4f75-a75a-9fa1812191c3
Faulting package full name:
Faulting package-relative application ID:

 

Gestern habe ich eine EDDM-LGAV-EDDM rotation ohne Probleme geflogen. Wenn ich mich jedoch anschliessend auf zB EDDF, EDDH oder EDDK stellen möchte, folgt der CTD.

(die CTDs waren bereits vor dem Kauf von EDDK und EDDF)

 

Ich verdächtigte stark ORBX, die .dll Fehler weisen doch auf Textureprobleme hin, wie ich vermute....

Deshalb habe ich im Addon Organizer einmal alles deaktiviert, was mit ORBX oder FTX zu tun hat und siehe da, keine CTDs mehr!

Edited by Patrik Wedam

Share this post


Link to post
Share on other sites
Romair
vor einer Stunde schrieb Patrik Wedam:

Leider kein Erfolg>

 

Faulting application name: Prepar3D.exe, version: 4.5.13.32097, time stamp: 0x5d8abf93
Faulting module name: ntdll.dll, version: 10.0.18362.719, time stamp: 0x64d10ee0
Exception code: 0xc0000374
Fault offset: 0x00000000000f92a9
Faulting process id: 0x3670
Faulting application start time: 0x01d5ff615e5beea7
Faulting application path: P:\P3D\Prepar3D.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 1b574c71-7253-4f75-a75a-9fa1812191c3
Faulting package full name:
Faulting package-relative application ID:

 

Gestern habe ich eine EDDM-LGAV-EDDM rotation ohne Probleme geflogen. Wenn ich mich jedoch anschliessend auf zB EDDF, EDDH oder EDDK stellen möchte, folgt der CTD.

(die CTDs waren bereits vor dem Kauf von EDDK und EDDF9

 

Ich verdächtigte stark ORBX, die .dll Fehler weisen doch auf Textureprobleme hin, wie ich vermute....

Deshalb habe ich im Addon Organizer einmal alles deaktiviert, was mit ORBX oder FTX zu tun hat und siehe da, keine CTDs mehr!

Hallo Patrik

 

Machst Du auch eine manuelle Kontrolle ob Du bei den besagten Addons (EDDK und EDDF) kein doppeltes ORBX Layout hast.

Das ORBX Vector Configuration Tool nützt da nicht da es nicht alle Layouts findet. ( Beispiel: nach EDDF suchen in D:\P3D\ORBX\FTX_VECTOR\FTX_VECTOR_APT\scenery und wenn da,

die Datei ABP_EDDF..bgl auf .off stellen.

 

Eine weitere Massnahme wäre:  Mit dem neuen FTX Central alles was mit FTX EU installliert ist deinstallieren und wieder neu installieren.

Grosser Nachteil, alle doppelten Layouts müssten wieder gesucht und auf .off gestellt werden.

Ich denke BASE sollte kein Problem sein. Vielleicht ist Vector ein Problemverursacher.

Wenn Du auch Vector deinstallieren müsstest, sind auch dort die doppelten Layouts wiederum auf .off zu stellen.

 

Kann Die auch mal mit Skype helfen wenn Du das wünscht. Habe vieeeel Zeit wegen CORONA.

Gruess Roger

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Patrik Wedam

@Romair

Danke für dein Angebot!

 

Mir steht gerade auch viel Zeit zur Verfügung. Deshalb habe ich kurzerhand den P3D komplett de- und wieder installiert.

Jetzt besteht der sim aus lediglich:

- P3D

- AddonOrganizer

- FS2Crew

- FSGlobal

- PMDG 777

- FSLabs A320

- aitraffic

- AS4

- mega airport LSZH

- aerosoft EDDK

 

Trotzdem, ntdll.dll nach 10min in EDDK am gate.

Werde es mal ohne aitraffic, AS4  und ohne FS2Crew versuchen

Share this post


Link to post
Share on other sites
AnkH

Nutzt Du den nvidia Frame Limiter? Wenn ja, nutze mal nur die globalen Settings für P3D im nVIDIA Control Panel ohne Frame Limiter.

  • Like 1

Share this post


Link to post
Share on other sites
Romair
Posted (edited)
vor 2 Stunden schrieb Patrik Wedam:

@Romair

Danke für dein Angebot!

 

Mir steht gerade auch viel Zeit zur Verfügung. Deshalb habe ich kurzerhand den P3D komplett de- und wieder installiert.

Jetzt besteht der sim aus lediglich:

- P3D

- AddonOrganizer

- FS2Crew

- FSGlobal

- PMDG 777

- FSLabs A320

- aitraffic

- AS4

- mega airport LSZH

- aerosoft EDDK

 

Trotzdem, ntdll.dll nach 10min in EDDK am gate.

Werde es mal ohne aitraffic, AS4  und ohne FS2Crew versuchen

Hallo Patrik

 

Da du ja ein äusserst komplizierter Fall hast, wäre es sinvoll, wenn Du zuerst nur den nackten P3D installierts und EDDK nur mit dem Stockairport testest.

Falls EDDK Stock gut ist, erst dann das EDDK Addon alleine wieder installieren, wieder testen und wenn gut, ein weiteres Addon installieren.

So wie ich sehe, hast Du bereits wieder zuviel miteinander installiert.

Da ist wirklich strukturiertes Vorgehen angesagt.

 

Zuerst muss doch der blute P3D Sim und dann mit dem EDDK Addon laufen da die "faulty application" ja der P3D ist.

 

Roger

 

 

 

 

 

Edited by Romair
  • Like 1

Share this post


Link to post
Share on other sites
Patrik Wedam

Möchte es nicht unterlassen, einen Zwischebericht zu verfassen. Da es schwierig ist, den genauen Zeitpunkt zu definieren, ab wann der Fehler auftrat, war minutiöse Planung nötig. Ich habe den P3D erstmal komplett de- und wieder installiert und auch beim Installieren der Addons darauf geachtet, ob und wo es die neuesten Versionen gibt. Zum Fehler ntdll.dll habe ich auch stundenlang zusätzlich recherchier und getestet, unter anderm hier:

https://www.avsim.com/forums/topic/519433-resolved-p3d-v4-crash-during-long-haul/

https://www.lifewire.com/how-to-fix-ntdll-dll-errors-2624474

https://www.avsim.com/forums/topic/570955-one-reason-for-p3d-ctd-ntdlldll-culprit-addressed/

 

Vor allem die beiden guides habe ich gründlich studiert:

https://www.avsim.com/files/file/87-avsim-prepar3d-guide/

https://www.avsim.com/files/file/93-avsim-ctd-guide/

 

Dabei habe ich noch

- Grafikkartentreiber aktualisiert

- BIOS aktualisiert

- BIOS auf Grundwerte zurückgesetzt

- sämtliche USB Treiber aktualisiert

- Treiber für alle Laufwerke aktualisiert

- und vor allem testen, testen, testen

 

Und bald stellte sich heraus, dass der Fehler in meinem aitraffic zu suchen ist. Irgendwie muss ich einmal ein unpassendes Modell erwischt haben. Aber welches von den ~700?!

 

Dazu hilft unter anderem folgender Eintrag:

https://www.prepar3d.com/SDKv4/sdk/content_error_reporting.html

 

Das tool AiAircraftTweaker

https://www.lorby-si.com/downloads.html

 

Das tool Model Scanner for FSX

https://flyawaysimulation.com/downloads/files/18876/fsx-model-scanner/

 

Nun gilt es, das leg, bei welchem der Fehler am meisten auftrat, (Dreieck EDDM, EDDF, EDDH) immer wieder und wieder zu fliegen, nachdem schrittweise der aktualisierte traffic eingefügt worden ist.

Zur Zeit habe ich noch 24 Modelle in der Qarantäne...

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Michael Briner
vor 9 Stunden schrieb Patrik Wedam:

Zur Zeit habe ich noch 24 Modelle in der Qarantäne...

 

WIe passend zur aktuellen Lage. Danke für den Zwischenbericht! Ich wünsche Dir viel Erfolg, Geduld und Nerven bei der Sache. Zu FSX Zeiten hatte ich auch solche Probleme, seit P3D aber eigentlich nicht mehr.

  • Like 1

Share this post


Link to post
Share on other sites
AnkH

Oh, ein riesen Aufwand, Hut ab davor. PS: ich behaupte mal salopp, dass all meine AI Traffic Modelle den SDKs soweit entsprechen, dass sie problemlos funktionieren, könnte Dir also mit dem einen oder anderen Modell vielleicht helfen. 24 Modelle finde ich jedoch etwas gar viel, trotzdem würde mich mal interessieren, was da so alles dabei ist, eventuell muss ich bei mir auch noch mal aufräumen.

  • Like 1

Share this post


Link to post
Share on other sites
Romair

Hallo Patrik

 

So viel ich mich erinnere, hat das ACA2017 von Peter ven der Veen beim scannen der Traffic.bgl auch angezeigt wenn FS9 Ai-Flugzeuge enthalten waren.

Ob das Toole heute noch taugt, müsste man ausprobieren.

Hoffe, dass Dein Repaufwand auch belohnt wird.

Roger

  • Like 1

Share this post


Link to post
Share on other sites
Max Knobel

Und wieso macht Ihr nicht vor jeder grösseren  Installation ein Image?

Dazu gehört auch eine Liste mit den Veränderungen und dem Datum.

Trotz dem, dass die Image-Programme immer besser und billiger werden wird das oft einfach nicht gemacht und ergibt anschliessend in einem einen Riesenaufwand.

 

Cheers Max

  • Like 2

Share this post


Link to post
Share on other sites
Bennie

Mache ich auch so.
Möglichst nie mehr als ein Addon an einem Tag installieren. Und jede Installation mit Datum und Uhrzeit notieren.
Dann kann man auch sehr gut nachvollziehen, welcher Ordner von welchem Addon angelegt wurde.
Ist zwar meistens selbsterklärend, aber manche Addons pfuschen da ganz schön rum.


Und wenn mal der Wurm drin ist, merkt man es, kann es dem Addon zuordnen und gezielt nach einer Lösung googeln.
Mit dieser Sorgfalt musste ich bisher noch nie auf ein Image zurückgreifen. Aber selbstverständlich mache ich _vor_ und ggf. nach größeren Installationen ein Image. Dafür lasse ich dann auch mal kleinere und unkritische Installationen "auflaufen".

  • Thanks 1

Share this post


Link to post
Share on other sites
Patrik Wedam

Nachdem ich nun tagelang ohne aitraffic erfolgreich mehrere legs in der "Krisenregion" durchgeführt habe, versuchte ich nun, eine erste Menge an Modellen wieder einzufügen und das gleiche leg zur gleichen Zeit zu starten.

Sofort war der erste CTD da!

 

Verwendete Modelle:

-AIA

717, 721, 722, 737MAX8, 737MAX9, B747-400LCF, Canadair CL-215, EMB120, EMB170, EMB175, EMB190, EMB195, F70, F100, DC8-73F, MD8X_Cone, MD8X_SD, MD90

 

- FAIB

alle Airbus und Boeing

 

- Raven

CRJ 200-1000, E170, E175

 

- TFS

alle Airbus und Boeing

 

SBAI

CS100, CS300

 

Nun heisst es also, schrittweise zurückzufahren, bis (hoffentlich) der Übeltäter gefunden ist.

Share this post


Link to post
Share on other sites
Romair

Hallo Patrik

Du hast einige Tools genannt mit den Du prüfen willst, ob Du eventuell ein FS9 Modell im Einsatz hast.

Ich mag mich erinnern, dass das ACA2017 (Author : Peter van der Veen ) beim scannen der Traffic Files anzeigt,

ob noch FS9 Modelle in Deinem AI vorhanden sind.

 

Diese Scanfunktion läuft automatisch durch alle installierten Traffic Files.

ACA2017 funktioniert auch im P3D v 4.

 

Gruess Roger

  • Like 1

Share this post


Link to post
Share on other sites
AnkH
Posted (edited)
vor 17 Stunden schrieb Patrik Wedam:

Verwendete Modelle:

 

Sind das alles bereits die P3Dv4 Konversionen aus dem AIG Forum? Ich habe da schon viel umgestellt und bei den anderen Modellen geprüft, dass alle FSX-nativ sind. Hiess auch, dass gewisse Modelle aus dem Sim geflogen sind.

 

EDIT: das Dumme an den P3Dv4 Konversionen ist, dass es damit vorbei ist mit Sharen unter Kollegen. Braucht immer noch .lua Scripts und Texture-Fallback-Ordner. Ansonsten würde ich Dir meine Sammlung natürlich zum Download anbieten.

Edited by AnkH
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...