Jump to content
AnkH

Prepar3d v4.5 ist raus...

Recommended Posts

AnkH

Kommt wohl für einige Entwickler und User ziemlich überraschend (auch für mich), trotzdem ist es so:

 

https://prepar3d.com/

 

Keine Ahnung, was da nun wirklich verändert worden ist, der Changelog ist mal wieder sehr lange. Worauf sicherlich viele hoffen: gemäss ORBX soll mit v4.5 die Problematik bei den Ladezeiten verschwinden.

 

Vermutlich komme ich am Weekend dazu, ein Update durchzuführen. Bin gespannt. Für alle Anderen: wie schon jetzt mit v4.4, wer PBR nutzen will, muss nun auch für v4.5 zwingend Content UND Client updaten.

  • Like 1

Share this post


Link to post
Share on other sites
Davidson
vor 3 Stunden schrieb AnkH:

Kommt wohl für einige Entwickler und User ziemlich überraschend (auch für mich), trotzdem ist es so:

 

https://prepar3d.com/

 

Keine Ahnung, was da nun wirklich verändert worden ist, der Changelog ist mal wieder sehr lange. Worauf sicherlich viele hoffen: gemäss ORBX soll mit v4.5 die Problematik bei den Ladezeiten verschwinden.

 

Vermutlich komme ich am Weekend dazu, ein Update durchzuführen. Bin gespannt. Für alle Anderen: wie schon jetzt mit v4.4, wer PBR nutzen will, muss nun auch für v4.5 zwingend Content UND Client updaten.

Ist doch wie jedesmal das selbe. Erst dann Update installieren wenn die anderen Hersteller ihre Programme kompatibel gemacht haben. Ich warte noch, sonst geht mein Traffic Programm vielleicht nicht mehr.

Share this post


Link to post
Share on other sites
kruser

Hier auf die Schnelle mal ein paar News..

"Aus Erfahrung klug"; dieser Werbespruch einer deutschen Firma würde ich zu Herzen nehmen und mal 14Tage zuwarten mit installieren, um so mehr das Update ja nicht riesige, sensationelle Neuheiten beinhaltet..

 

https://www.flusinews.de/2019/04/prepar3d-v4-5-verfuegbar/

 

 

Gruss

jens🛩️

Share this post


Link to post
Share on other sites
AnkH
vor 11 Stunden schrieb Davidson:

Erst dann Update installieren wenn die anderen Hersteller ihre Programme kompatibel gemacht haben.

 

Das mache ich meistens so, richtig. Ich vermute aber, dass bis zum Weekend alle meine Addons kompatibel sind.

Share this post


Link to post
Share on other sites
Michael Briner

Gut zu Wissen, dann ist wenigstens diese Hürde für das Update des FSLABS A320 weg.

Share this post


Link to post
Share on other sites
MartinM

Geht (momentan) nicht

  • ActiveSky P3dv4
  • VRS F/A-18E + SuperPack

 

Für VR Single Pass Stereo Flieger ein MUST fix.

Zitat
  • Fixed offset reflections in VR single pass mode.
  • Fixed minor visual artifacts with focal points in VR.
  • VR now remains enabled after a scenario reset.
  • Various performance improvements to single pass VR.
  • Added default VR window positions for global panels.

 

Share this post


Link to post
Share on other sites
AnkH

Für Active Sky gibt's längst ein Update, die sind nur nicht immer leicht zu finden, da als BETA klassifiziert (hatte aber noch nie ein Problem damit). Hier der Link:

 

https://hifisimtech.com/downloads/#ASP4

  • Thanks 1

Share this post


Link to post
Share on other sites
MartinM

Ein altes Problem ist zurück. VR ATC Fenster ist wieder unbrauchbar 

Share this post


Link to post
Share on other sites
Simmershome
Posted (edited)

Also ich hatte es auch probiert und bin wieder bei der v4.4.

Ich hatte in EDDP über drei Bildschirme in der v 4.4 knapp 50 Frames in der 4.5 nur noch 35 Frames. Noch schlimmer in EDDB am Gate 30 mit FTX. In der 4.4 habe ich wieder 30 Frames in der neuen 4.5 ganze 12 Frames.

Alles bei meinen gleichbleibend hohen Einstellungen.

Nur die Ladezeiten haben sich tatsächlich verkürzt. Aber bitte nicht so, das war ein Griff in die Schüssel.
Man kann ja auch mal ne Subversion auslassen. Diese wird es wohl sein.

 

Echt,mir sind die Ladezeiten völlig Pappe ( die Fotoplattenfüller von OrbX kaufe ich eh nicht) Die Frames sind mir aber nicht Pappe. Und wegen OrbX den ganzen Sim wieder zur verschlimmbessern, das hat mir gerade noch gefehlt.

Wirklich eine Nullnummer von LM, diesmal. Aber irgendwann ist halt jeder dran. Kann nur wieder besser werden…..
Selten, dass ich mal stinkig bin auf LM, diesmal aber gleich richtig.

 

Und ja ich bin nicht zu blöd zum wechseln. Zurück auf 4.4 war ich in 10 Minuten und alles ist wieder Palletti

 

Klare Nichtempfehlung und auf die v5 warten.... in der das dann hoffentlich wieder geht.

Edited by Simmershome

Share this post


Link to post
Share on other sites
AnkH

Wie so oft, dürfte auch hier wieder eine Mischung von verschiedenen Aspekten dazu führen, dass Du weniger FPS hast. In den Foren gibt es praktisch genau so viele User, die haben dieselben FPS oder gar leicht mehr. Wäre da also ein generelles und tieferliegendes Problem, hätten ausnahmslos alle User weniger FPS.

 

Hilft Dir zwar nix, aber vermutlich liegt der Hund iwo in Deiner ganz persönlichen Zusammenstellung begraben. Martin bspw. hat gemeldet, dass das ATC Window in VR wieder nicht mehr zu gebrauchen sei, etwas, was mir gar nie auffallen würde, da kein VR. Du nutzt drei Bildschirme und SLI, gut möglich, dass also das Update wiederum nur bei SLI oder Multimonitor zu Problemen führt. Auch das würden viele User nicht bemerken, die meisten sind wohl ohne SLI mit einem Monitor unterwegs.

 

Vielleicht müsstest Du da ansetzen? Mal komplett auf Zero zurück betreffend nVIDIA Profile, mal nur mit einer Karte testen? Mit nur einem Monitor? Ich weiss, dazu hätte ich auch keinen Bock, wenn 4.4 läuft, aber nur so könnte man rausfinden, was genau da im Argen liegt... Der Rest wage ich fast gar nicht zu fragen: Shaders gelöscht? Content UND Client installiert? Einen Default Flieger als Startszenario? Zwischen den Updates und Shader Löschen und danach den Rechner immer schön neu gestartet? nVIDIA Profil zurückgesetzt? Ev. mal die prepar3d.cfg gelöscht? Gibt soviele Dinge...

Share this post


Link to post
Share on other sites
MartinM

Also, ich bin gestern mal ein wenig bei LSZG, Malaga und Kanaren geflogen. Frames liegen bei ca 40fps in VR und 100+ ohne VR. Ich habe weder Shaders noch cfg Datein ersetzt beim Update. Jedoch habe ich in der EXE und DLL xml die Störfaktoren auf <Disabled>True gesetzt 😉

 

ActiveSky

TacPack.

IVAO Client

vLSO

Aerosoft Recorder

 

Diese sind alle nicht für v45 approved. Immer daran denken, wenn dann das Update da ist von der Software, schön brav auch wieder auf "False" stellen 😉

 

Ansonsten sehe ich nichts nachteiliges. Im Gegenteil, für VR gab eine Verbesserung die nun besser ist.

 

 

Share this post


Link to post
Share on other sites
Simmershome

Jepp in VR gab es eine Verbesserung, nützt mir aber nichts.

Ich rede auch von drei Bildschirmen und einer Auflösung von 5900 x 1080 (hätte ich dazu schreiben sollen).

In der v44 nimmt die Umschaltung von einem Bildschirm auf drei nur wenige Frames. In der 4. 5 extrem viele.

Das Problem war schon beseitigt und ist nun wieder da.

Cockpitbesitzer können damit nichts anfangen.

Share this post


Link to post
Share on other sites
MartinM

Ich verwende ProzessLasso. Ohne ProzessLasso läuft der XP, DCS und P3D deutlich schlechter. Vielleicht noch so ein Tipp

Share this post


Link to post
Share on other sites
Urs Zwyssig

Prepar3D V4.5 installiert und den ganzen morgen mit dem FSLabs A320X unterwegs gewesen. Aus meiner Sicht läuft es etwas flüssiger. Ich kann jedenfalls keinen Nachteil feststellen.

Ich muss noch erwähnen dass ich nur den Client neu installiert habe.

Gruss Urs

Share this post


Link to post
Share on other sites
MartinM

Muss mal noch die Scenery installieren. Es könnte an dem liegen

Share this post


Link to post
Share on other sites
AnkH

Habe nun Client und Content installiert, nach den ersten paar Testversuchen scheint alles beim Alten, keinen negativen Aspekt feststellen können. Im Gegensatz zu Rainer nutze ich aber auch nur einen Monitor, das Problem mit dem Multimonitorbetrieb scheint bestätigt und LM arbeitet an einem Hotfix.

  • Like 1

Share this post


Link to post
Share on other sites
Simmershome
vor einer Stunde schrieb AnkH:

bestätigt und LM arbeitet an einem Hotfix.

Hoffentlich bald😪

Share this post


Link to post
Share on other sites
AnkH

Ok, so problemlos scheint es doch nicht zu gehen, zumindest habe ich ebenfalls mit der Performance zu kämpfen, auch mit nur einem Bildschirm. Beispiel: aktivierte Wolkenschatten kosten bei mir fast 20FPS (!!!!). Ich kann gemütlich bei schönem, wolkenlosem Wetter herumfliegen mit meinen gelockten 30FPS, sobald auch nur ein Wölkchen am Himmel ist und die Wolkenschatten aktiviert, ist die Performance im Eimer und ich habe 10-15FPS. Muss da noch etwas rumspielen, habe einen Verdacht...

 

Verdacht bestätigt: ich habe vor einiger Zeit einen "Tweak" von Rob Ainscough in meine prepar3d.cfg übernommen, die deutlich bessere Schatten im VC und in den Szenerien zeichnet:

 

OPAQUE_SHADOW_TEXTURE_SIZE=1024
TRANSLUCENT_SHADOW_TEXTURE_SIZE=1024

 

Beide Werte auf "4096" gestellt, damit sind alle Schatten rund um den Flieger und die im VC gestochen scharf. Offensichtlich verträgt sich der Wert "4096" nicht mehr mit Prepar3d v4.5, ich musste da wieder auf "1024" runter und zack, der Performanceverlust bei Wolkenschatten ist wieder weg.

Edited by AnkH
  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites
Urs Zwyssig

Ich bin wieder zurück auf P3D V4.4. Ich habe heute einen Performance Vergleich gemacht, mit 4.5 verliere ich 5 bis 10 FPS. Also zurück auf Start oder besser auf 4.4.

Im LM Forum ist die Performance auch ein Thema, 4.5 scheint nicht so der Wurf zu sein!

Gruss Urs

  • Like 1

Share this post


Link to post
Share on other sites
AnkH

Jepp, zumindest mit Multimonitorbetrieb ist da ganz sicher was im Argen. Auch sonst ist LM dran, scheint also grundsätzlich ein Problem zu geben, welches auf die Performance drückt (Berichte über Lichter in der Nacht bis an den Horizont obwohl Draw Distance nicht auf max sind da bspw. ein Indiz).

 

Gewisse Dinge sind aber hier im Thread sicherlich noch erwähnenswert: es gibt offensichtlich durchaus User, die sich über schlechte Performance beklagen und nach dem Update NICHT die prepar3d.cfg gelöscht haben. Zumindest in einem Fall (ORBX Forum), hat ein Löschen der prepar3d.cfg den FPS Verlust sofort rückgängig gemacht. Für uns alte Hasen ist das natürlich keine wahnsinnige Erkenntnis, für etwas ungeübtere Simmer schon, zumal beim letzten Update es keine Rolle spielte, ob man die prepar3d.cfg löschte oder nicht.

 

Weiter ist es natürlich so, dass ich von vielen Performanceeinbrüchen vermutlich nichts mitkriege, da ich mit einem 30FPS Lock fliege. Ich würde also gar nicht bemerken, wenn meine theoretischen FPS von 65 auf 40 eingebrochen sind, da immer noch über dem Lock....

  • Like 1

Share this post


Link to post
Share on other sites
Romair

Wollte eigentlich mit dem Update noch etwas zuwarten hatte aber keine Geduld. Also wurde v4.5 installiert und es waren wieder Probleme zu lösen.

Bei mir waren die FPS gleich gut wie bei der v4.4 aber eben bei gelockten 30FPS  = A2A Comanche und LSZH  stabile 28 - 30.

Mit der v4.4 Prepar3D.cfg  und einer neuen etwas vereinfachen hatte ich keine FPS Unterschiede feststellen können.

 

Ich musste leider trotzdem wieder auf die v4.4 zurückstufen da ich die v4.5 fast nicht mehr komplett hochfahren konnte.

Beim hochfahren blieb die v4.5 regelmässig im Bereich 78 - 82% beim Uebergang "adjustment scenery objects" zu "loading autogenerated scenery" über Minuten stecken so, dass ich abbrechen musste.

Auch eine neue, leere .cfg löste das Problem nicht. Klar, die Prepar3D.cfg ist meiner Meinung nach da nicht so gross involviert denke ich.

 

Seit der Rückstufung läuft der P3D v4.4 wieder wie gewohnt.

 

Gruess Roger 

Edited by Romair
  • Like 1

Share this post


Link to post
Share on other sites
AnkH

Hast Du auch die üblichen Schritte nach einem Update durchgeführt? Hier nochmals aufgelistet, was ich gemacht habe:

 

Vor dem Update:

 

- alle Addons auf den neusten Stand gebracht (inkl. P3D v4.5 Kompatibilitätsupdates)

- Shaders auf Default zurückgesetzt (via PTA)

 

Nach dem Update:

 

- FTX Central geladen. Danach bei allen globalen Addons (FTX Global, FTX Vector, TreesHD, ORBX Libraries) auf "verify files" geklickt und überprüft. Gab für alle was zum Runterladen.

- Nochmals sämtliche Updater laufen gelassen.

- prepar3d.cfg angepasst (SimObjects Einträge, ansonsten läuft mein UT2 nicht). Dummerweise eben auch die Schatten-Tweaks (siehe oben).

- nach jeder Aktion den Computer neu gestartet. Sprich: nach dem Client Update, nach dem Content Update und nach jeder Aktion von FTX Central (mühselig...)

 

Aktuell wieder keine Probleme mehr... das kann sich schnell wieder ändern, da ich weiterhin nicht alles Testen konnte...

Share this post


Link to post
Share on other sites
MartinM

Komisch. War das ganze Wochenende am Fliegen. Auch heute Abend. Ich muss sagen, dass es bei mir Flüssig läuft im VR. Genau so wie vorher.

 

FTX Global

TE GB South

ORBX Libraries

CH Prof V4

 

Bei keinem der Komplexen Flieger habe ich das Gefühl, Performance verloren zu haben

 

A2A C172

A2A C182

A2A Spifire

Milviz DHC2

Milviz DHC3T

Milviz F4S/J Advanced

Aerosoft Airbus A320

 

Airline Traffic = OFF

GA Traffic = OFF

Ship Trafiic = 70%

Airport Traffic = Med

 

Share this post


Link to post
Share on other sites
Romair

Morge Christian

 

die Addons incl. Enshade und Envtex und Active Sky auf die Version 4.5 gebracht. FTX Central und Shader ja vergessen.

Danke für Deine Hilfestellung.

 

Das extrem langsame aufstarten hat mich genervt. Werde dann später nochmals mit dem 4.5 versuchen. Framerateneinbrüche hatte ich ja keine.

 

Habe aber einen sehr gut laufenden 4.4 deshalb werde ich noch etwas zuwarten.

 

Roger

Share this post


Link to post
Share on other sites
MartinM

Also AS Beta 7044  bringe ich gar nicht erst zum laufen. Knan keine Verbindung herstellen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...