Jump to content
Hans Tobolla

Windows 10, FSX installieren

Recommended Posts

Hans Tobolla

Hallo zusammen,

bei meinem neuen Rechner (i9-9900K, Geforce 2070Super 8 GB) kann ich zwar den FSX installieren, aber wenn ich einen Flug aufrufe, wird der Bildschirm schwarz mit einem großen Mauszeiger.
Vielleicht muss ich den FSX mit speziellen Service Packs an Windows 10 anpassen?  Vielleicht kann mir bitte jemand helfen, dieses Problem zu lösen.  
Gruß!
Hans

Share this post


Link to post
Share on other sites
AnkH

So wie ich es verstehe ("wenn ich einen Flug aufrufe"), kannst Du den FSX starten, aber sobald Du aus dem Startmenü loslegen willst, war es das? Oder startet der FSX überhaupt gar nicht erst?

 

Was ist denn das für einen Flug, den Du aufrufen willst?

 

Startest Du den FSX auch schön artig als Administrator? Ich hoffe, Du hast den FSX nicht unter C:\Programme installiert, das gibt ab und zu auch Probleme.

 

Der FSX benötigt tatsächlich "Service Packs", aber nicht explizit für Windows 10. Hast Du nur den nackten FSX installiert? Mindestens "FSX Acceleration" oder eben das "FSX Service Pack 2" muss da noch mit drauf, sonst geht nichts.

Share this post


Link to post
Share on other sites
Hans Tobolla

Hallo Christian,
ich habe ohne Probleme den FSX,  SP1 und Acceleration installiert. Soweit ich weiß soll man SP2 nicht installieren, wenn man Acceleration installieren will.
Ich kann den FSX ganz normal starten, und bei Freiflug das Gewünschte wählen. Wenn ich dann den Flug starte, wird der Bildschirm schwarz mit einem vergrößerten Mauszeiger, mit dem auch nichts zu machen ist.  Da komme ich nur mit STRG, Alt und Entf wieder zurück.
Ich habe den FSX zusammen mit Win 10 auf einer 500GB SSD installiert. Ich glaube nicht, dass das Problem ist.  Mit der Grafikkarte habe ich sonst auch keine Probleme.

Gruß!
Hans


 

Share this post


Link to post
Share on other sites
Gulfstream

Hallo Hans

kann dir nur meine Installationsroutine nennen und alles läuft (bei mir):

 

  • Installation schon under Admin, nicht erst die Ausführung
  • Es gibt im www eine Anleitung, welches Pack zuerst kommt unter  W10 (Relevanz? Weiss ich nicht, habe es aber befolgt) 
  • Nach dem jeweiligen Pack, jeweils Neustart

 

Viel Glück!

Markus

 

 

Share this post


Link to post
Share on other sites
AnkH
vor 3 Stunden schrieb Hans Tobolla:

 Wenn ich dann den Flug starte, wird der Bildschirm schwarz mit einem vergrößerten Mauszeiger, mit dem auch nichts zu machen ist.  

 

Und startest Du den Sim als Administrator? Der grosse Mauszeiger deuten für mich darauf hin, dass iwas mit der Grafik nicht passt, welche Auflösung hast Du im Simulator eingestellt? Beim FSX kann man ja noch 16bit auswählen, hast Du geprüft, dass die Einstellung auf 32bit steht und korrekt ist?

 

Die Tipps von Markus sind natürlich auch wichtig, insbesondere das artige Neustarten nach jeder Installation von FSX, SP1 und Acceleration.

 

Was Du sonst noch machen kann: schau mal in der FSX.cfg nach, was da eingestellt ist als Grafikkarte und/oder Auflösung.

 

Weiter: bis die Shader initial geladen sind, dauert es. Sicher, dass Du nicht zu früh den Bettel hingeworfen hast?

Share this post


Link to post
Share on other sites
Hans Tobolla

Danke für die Tipps.  Ich werde den FSX in einen seperaten Ordner installieren und auch  überprüfen, ob das richtige DirectX installiert ist.
Gruß!
Hans
 

Share this post


Link to post
Share on other sites
Hans Tobolla

Jetzt habe ich bei der FSX.cfg die Auflösung auf 1920x1080x32 eingestellt mit dem Ergebnis, dass ich zwar immer noch nach dem Aufrufen eines Freifluges sofort einen schwarzen Bildschirm in niedriger Auflösung bekomme, aber nicht mehr mit  einem Mauszeiger, sondern mit einem rotierenden kleinen Kreis, den ich mit der Maus verschieben kann.  Jetzt weiss ich wenigstens, dass die FSX.cfg die Anzeige beeinflusst...

 

Gruß!
Hans
 

Share this post


Link to post
Share on other sites
Gulfstream

Hans

Hast du den Standard Flug mal mit der C172 geladen ?
Hast du deine GeForce settings angeschaut? Vielleicht hat sich da was eingeschlichen.....
Wenn du die screen settings ausserhalb vom FSX komplett anderst einstellst (tiefe Auflösung), hast du dann die selben Resultate beim Neustart?

Markus

Gesendet von meinem SM-G965F mit Tapatalk

Share this post


Link to post
Share on other sites
AnkH
Am ‎16‎.‎11‎.‎2019 um 10:05 schrieb Hans Tobolla:

Jetzt weiss ich wenigstens, dass die FSX.cfg die Anzeige beeinflusst...

 

Der nächste logische Schritt wäre also: die aktuelle FSX.cfg mal iwo abspeichern als Backup und die FSX.cfg, die verwendet wird, löschen. Gehts dann immer noch nicht?

Share this post


Link to post
Share on other sites
Hans Tobolla

Hallo Christian,
ich dachte, ein Versuch ist es wert, und habe die FSXcfg vom alten Rechner(Win 7 32 Bit) in den neuen Rechner kopiert. Kein schwarzer Bildschirm mehr.  Inzwischen habe ich diese cfg mit dem FSX-Menue so getrimmt, dass ein Rundflug um Innsbruck auf der ORBX-Szenerie bis auf ein paar Kleinigkeiten eine feine Sache gewesen ist.  
Ich denke, dass beim Installieren des FSX eine cfg erzeugt wird, die nicht zu meinem neuen Win10 Rechner mit  64 Bit passt.
Mir fehlen leider die Fachkenntnisse um heraus zu finden, welche Zeilen es sind. 

Gruß!
Hans
 

Share this post


Link to post
Share on other sites
AnkH

Hoppla, das ist kurios. Daher war mein Rat, die FSX.cfg zu löschen, der FSX erstellt dann beim nächsten Start eine neue FSX.cfg. Ich würde das trotzdem mal noch machen, denn in der alten FSX.cfg hat es sicherlich einige Einträge drin, die beim neuen Rechner eher nicht so passend sind.

Share this post


Link to post
Share on other sites
Roland Grunder

Hallo Hans

 

Versuche mal, wenn du den schwarzen Screen vor dir hast, den FSX mit ALT / Enter in den Fenstermodus zu wechseln, dann mit den selben Tasten zurück.

Hat schon bei Usern funktioniert.

Zweite Möglichkeit, rechte Maustaste auf die FSX.exe und den Kompatibilitätsmodus auf Win 7 stellen.

 

Explitzit zu Win 10 gibt es keine Unterstützung, aber bei mir lief der FSX ohne SP, mit SP1 und SP2.

 

 

 

 

Share this post


Link to post
Share on other sites
flieger28

Das hatte ich auch mit dem FSX:SE. Erst lief er wunderbar ohne Probleme und dann nur noch der Schwarze Bildschirm. Ich bin der Meinung das es mit einem Windows Update zusammen hängt. Die einzige Möglichkeit es wieder zum laufen zu bringen war bei mir in der Config die DXPreview Version zu aktivieren. Allerdings hatte ich dann einige Grafikfehler. Letztlich war das dann am Ende der Auslöser für mich mir X-PLane zu kaufen. Habe den Schritt, jetzt nachdem ein Jahr vergangen ist, definitiv nicht bereut.

Share this post


Link to post
Share on other sites
Rolf Thöne

Zitat

Hallo Hans

kann dir nur meine Installationsroutine nennen und alles läuft (bei mir):

 

  • Installation schon under Admin, nicht erst die Ausführung
  • Es gibt im www eine Anleitung, welches Pack zuerst kommt unter  W10 (Relevanz? Weiss ich nicht, habe es aber befolgt) 
  • Nach dem jeweiligen Pack, jeweils Neustart

 

Viel Glück!

Markus

Zitat Ende

 

Hallo Markus,

"wie" Installation schon unter Admin???

Wenn ich auf die Setup-Datei gehe mit der rechten Maustaste erscheint nirgendwo der Hinweis "Als Admin ausführen", so kenne ich das jedenfalls

Gruß

Rolf

Share this post


Link to post
Share on other sites
Gulfstream

Rolf, du musst das exe File auf den Desktop ziehen und von dort aus via rechte Maustaste und Admin installieren. Aus dem Explorer raus gehts nicht.

Markus

Gesendet von meinem SM-G965F mit Tapatalk

Share this post


Link to post
Share on other sites
Rolf Thöne

Hallo Markus,

Danke!

 

Gruß

Rolf

Share this post


Link to post
Share on other sites
Rolf Thöne

Ich hatte das gleiche Problem wie Hans, schwarzer Bildschirm, alles was im www. so angeboten wird versucht, Kompatibilitätsmodus, Alt/enter etc. ...nothing.

Dann, wie Hans, die cfg aus dem alten Windows7-System genommen und siehe da, es funktionierte, die cfg habe ich dann natürlich in Bezug auf Grafik etc anpassen müssen.

Windows 10 erstellt augenscheinlich eine unbrauchbare cfg, so jedenfalls bei mir. Was nicht funktioniert ist die Umschaltung auf Full Screen mit alt/enter, schwarzer Bildschirm.

Ich habe jetzt meine geliebte LevelD in der neuen Windows10-tauglichen Version 1.50 installiert, auch diese läuft. Jetzt teste ich sukzessive meine Hardware aus meinem Homecockpit und da fängt es nicht gut an: MCP-Australia läuft nicht, Engravity CDU läuft nicht. Die Opencockpit-Module und der FDC-Throttle muss ich noch testen aber ich habe kein gutes Gefühl. Der Agronn-Yoke und die PFC-Pedals dürften dagegen funktionieren, sie benötigen ja keine Treiber. Was bleibt? Das Homecockpit mit 7 Monitoren weiter mit Windows 7 betreiben unter Verzicht auf Internetanschluß was speziell bei Active Sky (Wetter) nicht gerade schön ist .

Gruß

Rolf

Edited by Rolf Thöne

Share this post


Link to post
Share on other sites
Gulfstream

Hm, die unter W10 erstellte cfg könnte auch mein Problem sein (PMDG Probleme, sieht separater thread, schwarzer Rauch, keine Throttles etc....)

Muss das mal ausprobieren.

Markus


Gesendet von iPad mit Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...